Firing job but nothing happens

Post your support requests/solutions for phpJobScheduler [website]
neonlobster

Firing job but nothing happens

Postby neonlobster » Thu Sep 29, 2011 9:25 pm

I have a php job that should delete all records from a table, for example:
clean.php
-----------
include_once("functions.php");
db_connect();
$query="delete from jos_rwf_forms_1";
$result = mysql_query($query);
if (!$result) echo "There has been an error: ".mysql_error();
else echo "Deleted";
db_close();

The job is fired but nothing happens and in the error log I have:
Execution time: 44.99658 seconds via PHP CURL Output: * NO data

What is wrong here?

Thanks for this great script!

davidgwalker
MODS thats what I do that is! But definately NO mod music! It has to be ROCK!
Posts: 1809
Joined: Mon Oct 25, 2004 8:20 pm
Location: Huddersfield, UK
Contact:

Re: Firing job but nothing happens

Postby davidgwalker » Fri Sep 30, 2011 7:28 am

Hi,

Firstly try running the clean.php on its own in your browser (ie. http://www.yourdomain,com/folder/clean.php). Does it work?

If so then just add the FULL url for phpjobScheduler to fire and it should be fine.

It may have been failing due to file paths, so it could not find the functions.php file...

All the best

Dave

neonlobster

Re: Firing job but nothing happens

Postby neonlobster » Fri Sep 30, 2011 9:10 am

Indeed! It was a path problem, everything works fine now.

Thanks again!

All the best.

neonlobster

Re: Firing job but nothing happens

Postby neonlobster » Tue Oct 04, 2011 9:21 am

The script works when executing separately, the path is not a problem anymore, but i still get in error logs "No data" message.
It has something to do with the fact that the folder is passworded ?

Thanks for support!

davidgwalker
MODS thats what I do that is! But definately NO mod music! It has to be ROCK!
Posts: 1809
Joined: Mon Oct 25, 2004 8:20 pm
Location: Huddersfield, UK
Contact:

Re: Firing job but nothing happens

Postby davidgwalker » Tue Oct 04, 2011 9:43 am

Password protected folders/urls must be fired in a different manner.

see this post:
viewtopic.php?&f=1&t=727#p3337

neonlobster

Re: Firing job but nothing happens

Postby neonlobster » Tue Oct 04, 2011 10:33 am

I have protected /phpjobscheduler/pjsfiles folder and my php is in the phpjobscheduler/ folder.

What else can it be ?

davidgwalker
MODS thats what I do that is! But definately NO mod music! It has to be ROCK!
Posts: 1809
Joined: Mon Oct 25, 2004 8:20 pm
Location: Huddersfield, UK
Contact:

Re: Firing job but nothing happens

Postby davidgwalker » Tue Oct 04, 2011 10:43 am

In that case if you use a relative link, ie: foldername/filename.php
it should work!??

If you are using a explicit call, ie: http://www....
then you must enter the password and username as part of the url as previously shown in the link above.


Return to “phpJobScheduler [forum]”

Who is online

Users browsing this forum: No registered users and 2 guests