PHP Errors...

Post your support requests/solutions for phpMySQLAutoBackup [website]
shackrock

PHP Errors...

Postby shackrock » Sat Aug 20, 2011 11:39 pm

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/ssh2.so' - /usr/lib64/php/modules/ssh2.so: cannot open shared object file: No such file or directory in Unknown on line 0

Fatal error: Call to undefined function mysql_connect() in /home/mysite/public_html/phpMySQLAutoBackup/files/schema_for_export.php on line 22


The thing is, SSH2 is installed...
AND
mysql_connect() is installed and fully functional (the entire website uses it to connect to my DB that I'm trying to backup....)

Any ideas?

davidgwalker
MODS thats what I do that is! But definately NO mod music! It has to be ROCK!
Posts: 1809
Joined: Mon Oct 25, 2004 8:20 pm
Location: Huddersfield, UK
Contact:

Re: PHP Errors...

Postby davidgwalker » Sun Aug 21, 2011 8:02 am

Hello, thanks for posting the error.

Just had a quick look and on line 22 of the file schema_for_export.php is:

Code: Select all

$link = mysql_connect($db_server,$mysql_username,$mysql_password);
It is attempting to connect to your database (MySQL).


That is assuming you are using phpMySQLAutoBackup version "1.5.5"?
Please confirm?

Also to help me please let me know the following:
- php version?
- mysql veresion?
- platform? (ubuntu, windows, freebsd, etc...)

Thanks

Dave

shackrock

Re: PHP Errors...

Postby shackrock » Sun Aug 21, 2011 12:48 pm

Yes, using 1.5.5 of the script.

MySQL:
Server: Localhost via UNIX socket
Server version: 5.0.92-community
Protocol version: 10

PHP
5.3

OS
CentOS 5


I want to make clear though, that the library and the mysql_connect() function works perfectly when I go to run.php with my browser - it only fails with those errors when I run it from a cpanel CRON job...

So, it's as if some environment variables are not set, I just do not know how to set appropriately...

davidgwalker
MODS thats what I do that is! But definately NO mod music! It has to be ROCK!
Posts: 1809
Joined: Mon Oct 25, 2004 8:20 pm
Location: Huddersfield, UK
Contact:

Re: PHP Errors...

Postby davidgwalker » Sun Aug 21, 2011 8:25 pm

I see its, the cron config which is the issue.

Try asking your host.

If you do not get a positive result just use this:
http://www.phpjobscheduler.co.uk/
Its one of my other apps that will fire it for you and keep reports too.

Cheers

Dave


Return to “phpMySQLAutoBackup [forum]”

Who is online

Users browsing this forum: No registered users and 1 guest